Ouchy

23 02 2010

For the first time in 7 months, my legs hurt tonight. And by hurt, I mean ache. And by ache, I mean really ache. I actually pulled out the Dencorub tonight.

I don’t think it was the riding, I think it was the 50 squats I did last night. Quite easily in fact. I could’ve done more, but I was distracted by a 3 year old. I was doing the initial test for the twohundredsquats program and I did a lot more than I thought I could. I had been thinking that I hadn’t been doing them right, but if that had been the case, they wouldn’t ache this much would they?

Advertisements

Actions

Information

2 responses

23 02 2010
ajh

If it is just a good ache, ie DOMS, then probably just because you’ve used some muscles you don’t normally, or in a different way than normal. 50 is a pretty good effort for the first test. I just finished Week 4, and am about to hit the wall I think! Be careful of the knees. Just keep the knees behind the toes and you should be right.

24 02 2010
chrisfit2009

I had to look DOMS up, but yeah, that sounds like it.

I think maybe I did have the knees in front of the toes, mostly because I just did one with correct form and could barely stay upright. Centre of gravity too far back…wanted to tumble.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s




%d bloggers like this: